Наверх

Как установить PHP 8.1 на Debian 10/11

PHP 8.1 — большое обновление языка PHP. Оно содержит множество новых возможностей, и многие передовые фреймворки требуют наличия на сервере версии PHP 8.1 для работы всех функций. В первую очередь перед началом установки следует отметить, что PHP 8.1  в нижеприведенном репозитории больше недоступен на Debian 9.

Если вам нужна именно 8+ версия, лучше обновить дитстрибутив до версии Debian 11(bullseye)  или хотя бы Debian 10 (buster), иначе на Debian 9 вам придется довольствоваться PHP 5.6, максимум PHP 7.4.

Шаг 1: Обновите систему Debian

Рекомендую выполнять любую установку в обновленной системе Debian. Запустите предоставленные команды, чтобы обновить все пакеты и дополнительный выпуск вашей системы Debian.

sudo apt update
sudo apt -y upgrade

Проверьте версию операционной системы:

cat /etc/os-release

 

Если ваше ядро было обновлено, лучше перезагрузить систему, чтобы обновления применились.

sudo reboot

Шаг 2: Добавьте репозиторий Surý APT в Debian

Репозиторий DEB.SURY.ORG хранит различный софт под дистрибутивы Linux на основе Debian и Ubuntu. Он содержит последние бинарные сборки PHP 8.1. Репозиторий не входит в список стандартных, его необходимо добавить в систему вручную.

Установите необходимые временные пакеты

sudo apt update
sudo apt install -y lsb-release ca-certificates apt-transport-https software-properties-common gnupg2

Добавьте репозиторий Surý Debian PPA в свою систему

echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/sury-php.list

Импортируйте ключ GPG

curl -fsSL https://packages.sury.org/php/apt.gpg| sudo gpg --dearmor -o /etc/apt/trusted.gpg.d/sury-keyring.gpg

Убедитесь, что репозиторий работает, загрузив информацию о пакете из всех настроенных источников

sudo apt update

Если ошибок и конфликтов, связанных с Surý  не нашлось, можно двигаться дальше

Шаг 3: Установите PHP 8.1 на Debian

После того, как вы добавили репозиторий и подтвердили его работоспособность, можно приступать к установке системы PHP 8.1 или Debian 11 или 10.

sudo apt update
sudo apt install php8.1

Все пакеты зависимостей устанавливаются автоматически. Просто нажмите Y или Д на клавиатуре, чтобы продолжить:

 

После успешной установки можно проверить версию PHP:

php -v

 

Шаг 4, необязательный: Установите расширения PHP 8.1

Модули PHP 8.1 можно установить как пакеты, используя следующий синтаксис команды:

sudo apt install php8.1-<extension>

Вместо <extension> подставляйте название модуля, который вы хотите поставить, например

sudo apt install php8.1-mysql

Чтобы установить все часто используемые расширения PHP, выполните следующую команду:

sudo apt install php8.1-{bcmath,fpm,xml,mysql,zip,intl,ldap,gd,cli,bz2,curl,mbstring,pgsql,opcache,soap,cgi}

На середине установки согласитесь, нажав Y или Д:

 

Проверить загруженные модули PHP  можно с помощью команды:

php --modules

 

Источник: computingforgeeks.com

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *